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In Depth: Evolution

The Evolution program isn’t part of the OpenOffice.org suite. It was originally created by 

Ximian, an organization founded by the creators of the GNOME Desktop Project and 

acquired by Novell in August 2003. Even long after the acquisition, Evolution is still being 

improved by many of the key GNOME desktop developers.

Although it’s not explicitly described as such by its developers, Evolution is considered 

the “official” GNOME desktop e-mail program. The Evolution interface retains the same 

look and feel as many elements of the Ubuntu desktop. 

In terms of functionality, Evolution is similar to Microsoft Outlook. As well as being a 

powerful e-mail client, it incorporates contacts management, a calendar, a to-do list, and 

a memo function. Evolution is even able to connect to Microsoft Exchange (2000 and 

later) groupware servers and synchronize with contact and calendar data, in addition to 

fetching e-mail. Of course, it can also connect to standard POP3/SMTP e-mail servers, as 

well as IMAP, Novell GroupMail, and a handful of other mail server technologies. This 

means it is compatible with practically every e-mail system in use today. For more details 

about how to set up Evolution, see Chapter 8. 

Although Evolution offers many of the functions of Microsoft Outlook, it differs in some 

key ways. This chapter describes how to use Evolution’s main features.

Evolution Modes
Evolution consists of five components: Mail, Contacts, Calendars, Memos, and Tasks. 

These are interconnected but operate as separate modes within the program. Each mode 

can be selected using the switcher located at the bottom-left side of the program window. 

Simply click the button for the mode you wish to use. The program window, toolbar, and 

menu system will change to accommodate whichever mode is selected. Figure 27-1 shows 

the program in the default Mail mode.
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■Tip  You can shrink the switcher component to small icons by clicking View ➤ Switcher Appearance ➤ 

Icons Only.

Figure 27-1. You can switch between Evolution’s modes by clicking the buttons at the bottom 

left of the program window.

The five Evolution modes work as follows:

Mail: The e-mail component is at the heart of Evolution, and all the functions you 

might be used to are provided. Once the Mail mode is selected, at the top left of the 

program window, you’ll find the mail folders. These include the Inbox and Sent folders, 

along with any other mail folders you create. On the right is the list of e-mail messages, 

and beneath this is the message preview pane, where the body of any message you 

select will be displayed. Above the message list is the search box, which works like 

most e-mail search routines: type the relevant word(s) and press Enter. Notable icons 

running along the top of the window include the New button, which will let you 

compose an e-mail message, and the Send/Receive button, which will download new 

messages and also send any messages in the Outbox folder. 
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Contacts: Tied in with the mail function but acting as a separate and very powerful 

entity on its own, the Contacts mode lets you store every pertinent detail about 

colleagues, friends, and others. Once the mode is selected, at the left side of the 

program window, you’ll see the various contact folders. For most users, there will be 

just one, named Personal, but if you specified a groupware server during setup, you 

will also be able to connect to this by clicking its entry. At the top right is the list of 

contacts. Clicking any contact displays that individual’s information at the bottom of 

the window, in the contact information area. The search bar at the top of the window 

beneath the toolbar lets you quickly search for contacts by name. The New button on 

the toolbar lets you create a new contact, where you can enter a wealth of data. To edit 

an existing entry, double-click its entry and fill in the additional details.

Calendars: The Calendars mode is arguably Evolution’s second most useful function. 

You can add events in half-hour increments, and view your schedule in day, week, 

and month views by clicking the relevant button on the toolbar. Once the mode is 

selected, at the top left of the program window, you’ll find the various calendars you 

can access. For most users, the Personal calendar will be the principal one, but you 

can also access shared calendars here. Assuming the default day view is in operation, 

beneath this you’ll see the monthly calendar and, in the middle of the program 

window, the appointment list, with half-hour entries covering the working day. By 

default, the current day is shown. To select a different day, simply double-click the 

day in the month view. You can switch among day, week, and month appointment 

views by clicking the Day, Work Week, and Month buttons on the toolbar. On the 

right of the window, any tasks and memos that have been created are displayed, as 

described next. 

Memos: The best way to think of Evolution’s Memos mode is as a personal notepad. 

Once the Memos mode is selected, the list of memos will appear on the right side of 

the screen, and the contents of the memo at the bottom. Memos can consist of virtu-

ally any amount of text, along with attachments. They’re ideal for jotting notes during 

phone calls, for example.

Tasks: Effectively, this is a simple to do list. Once the mode is selected, your tasks will 

be listed on the right side of the program window. Beneath this will be details of any 

selected task. 

Basic E-Mail Tasks
Evolution’s e-mail functionality is arguably the heart of the program. Although it offers a 

lot of features, it is quite simple to use. If you’ve ever used any other mainstream e-mail 

client, such as Microsoft Outlook, you have a head start. 
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This section describes how to accomplish several everyday tasks within the e-mail 

component of Evolution. When you start Evolution, the e-mail mode is selected automat-

ically. However, if it isn’t, or if you’ve switched to a different mode within the program, 

simply click the Mail button at the bottom left of the program window. 

Sending and Receiving E-Mail

Once Evolution has been set up correctly to work with your e-mail servers, as outlined in 

Chapter 8, you can simply click the Send/Receive button on the toolbar to connect to the 

server(s) and both send and receive e-mail.

You may need to enter your password if you didn’t enter it during setup. You can check 

the Remember Password box to avoid having to type it again, but this will mean the pass-

word is stored on your hard disk, posing a security risk if other people have access to your PC. 

■Note  Although e-mail is normally sent as soon as you click the Send button when composing it, if the 

sending has been delayed for any reason (such as being offline at the time), it will be sent as soon as you click 

the Send/Receive button. Until that point, it will be held in the Outbox folder on the left side of the program 

window. 

Any outstanding mail is sent first, and then the receiving procedure is started. As shown in 

Figure 27-2, a status dialog box will tell you how many messages there are and the progress 

of the download. Clicking the Cancel button will stop the procedure (although some 

messages may already have been downloaded). When you get a new e-mail, an envelope 

icon blinks in the notification area in the top right of the desktop, and a small window 

appears to tell you that you have mail.

Figure 27-2. You’ll see a progress display whenever you click the Send/Receive button.
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E-MAIL SIGNING AND ENCRYPTION

In Chapter 9, you learned how to use the Seahorse application to set up a public key pair. This allows you 

to encrypt e-mail messages destined for other people, so that only they can read the messages (provided 

you have their public key), and digitally sign your own e-mail, so recipients can be sure messages came 

from you (provided they have your public key). If you’ve followed the instructions to set up the key pair, 

you now need to configure Evolution to use it. After doing this, and when you send a new e-mail message, you 

can select whether you wish to encrypt the e-mail and/or digitally sign it. 

Remember that setting up encryption is not obligatory, and relatively few people in the wider world 

use e-mail encryption or signing. 

Assuming you’ve already set up an account within Evolution, here’s the procedure for configuring 

Evolution for encryption and digital signing:

1. Click Edit ➤ Preferences, ensure the Mail Accounts icon is selected on the left side of the window, 

and select your mail account in the list on the right side of the window. Then click the Edit button. 

In the dialog box that appears, click the Security tab. 

2. You now need to find your PGP key ID using Seahorse. Click Applications ➤ Accessories ➤ Passwords 

and Encryption Keys. Locate your key in the list under the My Personal Keys tab, and look under 

the Key ID heading. You should see an eight-character hexadecimal number, like F0C1B52A. Write 

this down, remembering that any 0 you see is a zero, and not the letter O. 

3. Switch back to the Evolution dialog box and type the PGP key ID you found into the PGP/GPG Key 

ID box. If you wish every e-mail message you send to be digitally signed automatically, which is a 

good idea (the message itself won’t be encrypted, so even if the recipients are not using encryption, 

they will still be able to read it), put a check in the Always Sign Messages When Using This Account 

box. Then click OK. 

Encrypting outgoing messages, or signing them if you haven’t selected to automatically do so, is 

easy. When composing a new message, click the Security menu entry and select either or both PGP Sign 

and PGP Encrypt. Remember that you’ll need to have imported the recipient’s public key via Seahorse if 

you want to encrypt a message addressed to that person, or you’ll see an error. If you sign a message, 

upon sending it, you’ll be prompted to enter the PGP passphrase you entered when you created the key 

pair back in Chapter 9. 

If upon sending an e-mail message, you see the error message “Failed to execute GPG: Broken 

pipe,” it’s likely you mistyped your key ID when you configured Evolution. Try again. 

If you receive a message that has been encrypted using your public key, Evolution will automatically 

prompt you to enter your PGP passphrase to decrypt it. This is the passphrase you entered when creating 

your key pair back in Chapter 9. 

When you receive a message from someone who uses digital signing, and you have that person’s 

public key, the message should contain a green bar along the bottom containing the words “Valid signa-

ture.” If you see words to the effect that the signature is invalid, or if the signature is missing, then you 

should be suspicious and independently verify the authenticity of the e-mail message.
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Reading E-Mail

Simply click an e-mail message to view it in the preview pane at the bottom of the screen. 

Alternatively, you can double-click a message to open it in its own program window 

(selecting a message and pressing Enter will have the same effect).

As with most e-mail clients, any unread messages in the list appear in bold, and messages 

that have been read appear in ordinary type. By default, each message is marked as read 

after 1.5 seconds, but you can alter this value. To change it, click Edit ➤ Preferences, click 

the Mail Preferences icon in the Preferences dialog box, click the General tab, and then 

change the value under the Message Display heading. A value of 0 will cause the mail to 

switch to read status as soon as it’s clicked, which can be useful if you want to quickly clear 

a lot of messages. 

You can also mark many messages as read by highlighting them all, right-clicking an 

individual one, and selecting Mark As Read from the menu that appears. You can select 

multiple messages in the usual way: Shift-click to select a consecutive list, or Ctrl-click for 

nonconsecutive selections.

Deleting Messages

You can delete messages by highlighting them and pressing the Delete key. Alternatively, 

right-click any message (or a selection of them) and select Delete. The message will then 

be moved to the Trash folder. To empty the Trash folder, right-click the folder, and select 

Empty Trash, as shown in Figure 27-3. 

Figure 27-3. To permanently delete messages, right-click the Trash folder and select Empty Trash.
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If you move any messages from folder to folder, as described later in the “Sorting and 

Filtering Messages” section, a copy of the mail will end up in the Trash folder. This is 

because Evolution doesn’t literally move messages. Instead, it copies them from the old 

to the new location and deletes the original. This can be a little disconcerting at first, but 

there’s nothing to worry about. The mail message will remain wherever you moved it, and 

it won’t disappear.

Flagging Messages

You can flag messages in a variety of ways to help remind you of their status or purpose. 

The simplest form of flagging is to mark a message as important: right-click the message 

and select Mark As Important, or click in the space beneath the Important column (this is 

located to the left of the From column). This will add an exclamation mark symbol along-

side the message. 

Alternatively, you can add several different flags by right-clicking a message and selecting 

Mark for Follow Up. The choices, which can be selected from the Flag drop-down list in 

the dialog box that appears, range from Do Not Forward to No Response Necessary and 

Review. This heading will then appear in the message preview at the bottom of the window 

whenever the mail is selected.

If you prefer a simple color-coding scheme, you can mark up a message by right-clicking 

it and selecting Label. Then assign a color. As you’ll see, each color relates to a key word or 

phrase. You can edit both the colors and the key phrases by clicking Edit ➤ Preferences, 

clicking Mail Preferences on the left of the dialog box, and clicking the Labels tab. 

IMPORTING OUTLOOK E-MAIL VIA THUNDERBIRD

Back in Chapter 4, we discussed a method of exporting e-mail from various Microsoft e-mail programs, 

which use proprietary formats, so that it can be imported under Ubuntu. To recap, you can install the 

Mozilla Thunderbird e-mail client under Windows, import your e-mail into it from Outlook or Outlook 

Express, and then export Thunderbird’s mailbox (.mbox) files for importing within Evolution.

If you followed these instructions and now have the .mbox files ready for use with Evolution, it’s 

easy to import them. Click File ➤ Import. In the Import dialog box, click the Forward button, and select 

Import a Single File. Click Forward again, and click the Filename drop-down list. This will open a file 

browsing dialog box, in which you can locate the .mbox file, and click Open. If you have more than one 

.mbox file, you’ll need to import each one manually. The Automatic entry in the dialog box refers to the 

file type and will select the correct file type by file extension.
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Composing a Message

Creating a new e-mail is as simple as clicking the New button at the top left of Evolution’s 

program window. Fill in the To and Subject details as usual, and then type in the main 

body of the message.

To add a CC or BCC, click the To button, and select addresses from your contacts list in 

the dialog box that appears (selecting the CC or BCC button as appropriate). Alternatively, 

if you would like to have the CC and BCC fields visible and available at all times, click their 

entries under the View menu of the Compose a Message window.

As with most Microsoft mail programs, new e-mail can be sent either as plain text or as 

HTML. Plain text mode is the default. To switch to HTML, click the entry on the Format 

menu. The advantage of HTML mail is that you can vary the style, size, and coloring of 

text, so you can emphasize various words or paragraphs, as illustrated in Figure 27-4. In 

addition, if you click Insert ➤ Image, you can insert pictures from the hard disk. Other 

options on the Insert menu let you insert tables, dividing lines (click the Rule menu entry), 

and hyperlinks.

Figure 27-4. New messages can be formatted in HTML, allowing you to change the color of 

text as well as its size.
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The disadvantage of HTML e-mail is that the person receiving the message will need an 

HTML-compatible e-mail program to be able to read it. Your mail is also more likely to be 

tagged as spam by the recipient’s server, due to the widespread abuse of HTML and images in 

mail by spammers.

■Tip  Many people in the Linux community frown on HTML-formatted e-mail and prefer plain text messages. 

Words are automatically spell-checked in the new e-mail, and are underlined in red 

if the spell checker thinks they are misspelled. To correct the word, right-click it, select a 

dictionary, and then select the correctly spelled word from the list provided. 

By default, if you chose the English language during the installation of Ubuntu, the 

Evolution spell checker will offer only an English (American) dictionary. You can switch 

to a British or Canadian dictionary by selecting Edit ➤ Preferences in the main Evolution 

window, clicking the Composer Preferences icon, and then clicking the Spell Checking 

tab. Select an alternative dictionary or multiple dictionaries by checking the boxes to the 

left of the dictionary names.

While composing an e-mail, you can switch languages by selecting Edit ➤ Current 

Languages in the menu of the Compose Message window. If the language that you require 

is not listed, this means that you need to install an additional Aspell dictionary package 

with the Synaptic Package Manager. These dictionary packages usually have a two-letter 

suffix indicating the language that they support; for example, aspell-fr is the French 

dictionary package.

Creating an E-Mail Signature

E-mail signatures are the blocks of text that appear automatically at the end of new e-mail 

messages you compose. They save you the bother of typing your name and contact details 

each time. To create an e-mail signature, follow these steps:

1. Click Edit ➤ Preferences. Select Composer Preferences from the left side of the 

dialog box, and click the Signatures tab.

2. Click the Add button at the top right of the dialog box. 

3. In the Edit Signature dialog box, type what you wish to appear as your signature. 

The signature can either be in plain text or HTML (click Format ➤ HTML). Don’t 

forget that in HTML mode, you can insert lines (Insert ➤ Rule), which can act as a 

natural divider at the top of your signature to separate it from the body of the e-mail, 

as shown in the example in Figure 27-5.
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Figure 27-5. Creating an e-mail signature saves you from having to type your contact 

details each time. 

4. Click the Save and Close icon at the top left.

5. Click Mail Accounts in the Preferences dialog box, and double-click your mail 

account in the list on the right side. 

6. In the dialog box that appears, click the Identity tab. In the Signature drop-down 

list, click the signature you just created. 

7. Click OK and then Close in the Preferences dialog box. Your new signature will then 

automatically appear in new messages. 

■Tip  Enter a few carriage returns at the top of your signature so that when you create a new e-mail, you 

have enough space to click and type without accidentally clicking within the signature. 

Advanced E-Mail Tasks
Evolution offers several features that can help you to organize your e-mail. You can create 

new folders, as well as filter, sort, and search through your messages.
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Creating New Folders

If you want to better organize your e-mail, you can create your own folders, which will 

then appear in the list on the left side of the program window. 

To create a new top-level folder, which will appear in the list alongside the standard 

folders (Inbox, Junk, Outbox, and so on), right-click On This Computer, and select New 

Folder. Then make sure that On This Computer is selected in the folder view of the dialog 

box that appears. Type a name and click Create.

You can also create second-level folders, which will effectively be “inside” other folders 

and will appear indented below their parent folder within the list. For example, you might 

want to create a series of folders within the main Inbox folder to sort your mail from various 

individuals or organizations. To do this, right-click Inbox, select New Folder, and give the 

folder a name in the dialog box that appears, as shown in Figure 27-6. Once the new folder 

has been created, click the arrow next to Inbox to expand the display to show your new 

subfolder. 

Figure 27-6. You can create your own folders to better organize your mail.

You can then drag-and-drop messages into the new folders, or simply right-click them, 

select Move to Folder, and select the folder from the dialog box that appears. This can be 

useful if you wish to select a handful of messages by holding down the Ctrl key. All you 

need to do then is right-click one of them and select Move to Folder.

You can also copy messages from one location to another, thus producing two copies 

of the same message. Simply right-click the message, select Copy to Folder, and select the 

folder from the list. Alternatively, you can hold down the Ctrl key while you drag the message 

to the new location.
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Dealing with Junk E-Mail

Evolution includes intelligent junk mail filtering. Any mail that Evolution thinks is spam 

or junk mail will end up in the Junk folder. When you first start using Evolution, you should 

check the folder regularly, because there’s a chance Evolution might have made a mistake. 

However, this is a good thing, because by right-clicking the message and selecting Mark 

As Not Junk, the Evolution junk mail filter will be able to better understand what to consider 

as junk in your particular Inbox. 

In a similar way, if you find that Evolution misses a junk e-mail, and it ends up in your 

Inbox, you can right-click it and select Mark As Junk. Alternatively, select it and click the 

Junk icon on the main toolbar.

To empty the Junk folder, select all the messages (Ctrl+A), right-click, and select Delete. 

Bear in mind that, as with any folder, once the messages are deleted, they will appear in 

the Trash, and you can restore them from there if necessary.

Sorting and Filtering Messages

You can filter incoming messages according to practically any criteria, including who sent 

the message, its subject line, words within the body of the mail, its size, or even if it has 

attachments. Coupled with the ability to create folders, this allows you to automatically 

sort messages as soon as they’re received.

To set up filters, click Edit ➤ Message Filters. Click the Add button and, in the Rule Name 

box, start by giving the new rule a descriptive name by which you’ll be able to recognize it 

in the future. You might think this isn’t important, but you may create tens, if not hundreds of 

filters, so being able to identify filters will be very helpful.

As shown in Figure 27-7, the Add Rule dialog box is split into two halves: “Find items 

that meet the following criteria” and “Then.” As implied by the labels, if the selected 

conditions are met, then the selected actions will take place.

The “Find items” part is used to identify the mail. You can select to filter based on 

almost any criteria, such as who appears in the Sender field of the message, words that 

appear in the Subject line, the date sent, and so on. Simply select what you require from 

the drop-down list directly beneath the Add Filter Criteria button. In most cases, you’ll 

then need to specify details for the filter. For example, if you select to filter by the address 

of the individual sending the e-mail, you’ll need to provide that e-mail address. 

■Tip  Several If rules can be created. For example, you could create a rule to filter by the address of the 

sender, and then click the Add Filter Criteria button to create another rule to filter by text in the Subject line. 

By clicking If All Criteria Are Met in the Find Items drop-down list, the mail will be filtered only if both conditions are 

met. By selecting If Any Criteria Are Met from the drop-down list, the mail will be filtered if either condition is 

met.
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Figure 27-7. Creating message filters lets you automatically organize your e-mail as soon as 

it’s received.

Once you’ve set the Find conditions, you need to select from the Then section of the 

dialog box. This tells Evolution what to do with the filtered mail. The obvious course of 

action is to move the e-mail to a particular folder, which is the default choice, but you can 

also delete the e-mail, set a particular flag, beep, or even run a particular program! As with 

the rules for finding items, you can set more than one condition here, so you can have 

Evolution beep and then delete the message, for example.

Creating Search Folders

Evolution’s search folder feature is a more powerful alternative to message filters. Using 

search folders, you can filter mail based on a similar set of criteria, but you can choose to 

include messages in the results that might be associated with the filtered messages. For 

example, if you choose to filter by a specific individual’s e-mail address, you can select to 

have any replies you sent to that person included in the results, rather than simply messages 

received from her. In addition, you can apply search folders to specific e-mail folders on 

an ongoing basis, rather than all incoming e-mail. 

It’s important to note, however, that a search folder isn’t a filter. The messages aren’t 

moved into the new folders. They stay where they are in your Inbox (or any other folder 

they might be contained in). Despite the name, search folders are actually little more than 

saved searches. They just act like filters. However, search folders are dynamically updated—if 

a message is deleted from the Inbox folder, for example, it will also stop appearing in any 

relevant search folder. 
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You can create a new search folder by clicking Edit ➤ Search Folders and then clicking 

the Add button. You can choose to search specific folders (the default), all local folders, or 

all active remote folders (which includes any of your mail stored on a server elsewhere). As 

with creating message filters, clicking the drop-down box beneath the Add button will let 

you select filtering criteria. The choices are broadly similar to those for message filters, in 

that you can filter by e-mail address, size of e-mail, message body, and so on. 

In the Include Threads drop-down box, you can select what kind of results you would 

like the search filter to return:

• None simply returns e-mail messages matching the criteria.

• All Related returns every single message that is associated with the criteria.

• Replies returns results that include replies to the messages returned via the filter.

• Replies and Parents returns results that include replies and also any initial message that 

you or others might have sent that inspired the message included in the filter results.

• No Reply or Parent returns results that include only initial messages sent to you.

Search folder results are listed under Search Folders on the left side of the Mail mode 

window. The Unmatched folder, present by default, simply shows any messages that 

aren’t included in any of the search folders.

The search folder feature is very powerful and worth spending some time investigating.

TIPS FOR USING EVOLUTION E-MAIL

In many ways, Evolution is similar to e-mail programs you might have used in the past, but it also has a 

few of its own quirks and idiosyncratic ways of working. Here are a handful of preferences you might 

want to set to have Evolution behave in a more familiar way:

• Forward e-mail inline: If you attempt to forward a message, Evolution will attach it to a new 

message as a file. The person receiving the e-mail will then need to double-click the file to view 

the forwarded e-mail, which can be confusing. The solution is to make Evolution forward the 

message in-line, which is to say that Evolution will quote it beneath the new mail message, like 

Microsoft e-mail programs. To do this, click Edit ➤ Preferences, click Composer Preferences on 

the left side of the dialog box, click the Forward Style drop-down list, and select Inline.

• Change the plain text font: Any messages sent to you in plain text format, rather than HTML, will 

appear in the message preview pane in a Courier-style font. To have messages display in a more 

attractive and readable typeface, click Edit ➤ Preferences, select Mail Preferences on the left side 

of the dialog box, and then remove the check from Use the Same Fonts As Other Applications. In 

the Fixed Width Font drop-down list, select an alternative font. The standard Ubuntu font is called 

Sans and is a good choice.
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• Always create HTML e-mail: Evolution defaults to plain text e-mail for any new messages you 

create. If you want to always create HTML messages, click Edit ➤ Preferences, click Composer 

Preferences on the left side of the dialog box, and then put a check alongside Format Messages in 

HTML. 

• Empty Trash on exit: To automatically get rid of deleted messages each time you quit Evolution, 

click Edit ➤ Preferences, click Mail Preferences on the left side of the dialog box, and put a check 

alongside Empty Trash Folders on Exit. Then select how often you would like this to happen from 

the drop-down list: every time you quit Evolution, once per day, once per week, or once per month. 

• Vertical message window: As an alternative to positioning the message preview window beneath 

your messages, Outlook lets you position the message at the right of the message list, thus forming 

three vertical columns (folders, messages, and preview). To switch to this view under Evolution, 

click View ➤ Preview ➤ Vertical View. 

Contacts
Evolution includes a powerful contacts manager component that can catalog information 

about individuals. At its most basic, the contact manager stores e-mail addresses for use 

within the e-mail component of Evolution, but you can enter significant additional data 

about each individual, including addresses, phone numbers, fax numbers, and even a 

photograph for easy identification. This should allow Evolution to become your sole 

personal information manager.

To switch to the Contacts mode, click the button at the bottom-left side of the program 

window. Once in the Contacts mode, you can view information in several ways. Click View ➤ 

Current View to choose from the following views:

Address Cards: This is the default view and shows the contacts as virtual index cards 

arranged alongside each other at the top of the program window. Click the scroll bar 

beneath the cards to move through them. 

List View: This shows the contact information as a simple list, arranged vertically, 

with various elements of the contact’s personal information listed alongside, such as 

phone numbers and e-mail addresses. 

By Company: This organizes the data in a similar way to List view but sorted by the 

company the contacts work for (if such data has been entered into the contact entries).

Adding or Editing Contact Information

By far, the best way of initially building up your contacts list is to right-click e-mail addresses 

at the head of messages, in Mail mode, and select Add to Addressbook. This will add a 

simple contact record consisting of the individual’s name and e-mail address. 
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When using Microsoft mail applications, simply replying to an e-mail from an individual is 

enough to add that contact to your address book. Evolution is capable of this behavior, 

too, but the feature isn’t activated by default. To set this up, click Edit ➤ Preferences, click 

Mail Preferences on the left side of the dialog box, and click the Automatic Contacts tab. 

Next, put a check in the box marked Automatically Create Entries in the Addressbook 

When Responding to Messages. From the Select Address Book for Automatic Contacts 

drop-down list, select Personal. In the same dialog box, you can import contacts from the 

Pidgin instant messaging client.

You can then edit the contact details by double-clicking the entry in Contacts mode. 

This will let you enter a variety of information, as shown in Figure 27-8. To import a photo 

for this contact, click the top-left icon. You can use any picture here, and you don’t need 

to worry about its size, because it will be resized automatically by Evolution (although its 

aspect ratio will be preserved). The imported photo will appear in the lower area of the 

Contacts window when you click the contact’s name.

Figure 27-8. A lot of information can be entered for each contact, and, by clicking the button 

at the top left, you can also add a photograph.
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Creating a Contact List

Contact lists are simply lists of e-mail addresses. Once a list is created, you can right-

click its entry in the contacts list, and then choose to send a message to the list or 

forward it to someone else as a vCard. The obvious use of contact lists is for sending 

group e-mail messages. 

■Note  vCard is a virtual business card. Effectively, it’s a small file that contains personal information. As 

well as personal data, vCards can contain pictures and audio clips. They’re understood by practically all business- 

level e-mail programs, including Microsoft Outlook and Apple Mail.

To create a contact list, click the small down arrow next to the New button in Contacts 

mode, and select the option from the list. Give the list a name in the relevant box, and 

simply click and drag contacts from the main program pane onto the bottom of the Contact 

List Editor pane. This will automatically add their names and e-mail addresses. Alterna-

tively, you can type their e-mail addresses manually into the field under the Members 

heading, and then click the Add button, which can be useful if the individual isn’t in your 

contact list.

By checking the Hide Addresses When Sending Mail to This List option, you can ensure 

that the e-mail addresses are added to the BCC field of a new message, so people on the 

list don’t see the others on the list.

Calendars
The Calendars mode of Evolution allows you to keep an appointments diary. Entries can 

be added in half-hour increments to the working day, and you can easily add events to 

days that are weeks, months, or even years in advance. Viewing a day’s appointments is as 

simple as clicking its entry in the monthly view at the top right of the program window. 

Specifying Appointment Types

You can make the following three types of diary entries: 

Appointments: These are events in your diary that apply to you only. You might have 

a meeting with a colleague, for example, or might simply want to add a note to your 

diary to remind you of a particular fact.
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All Day Events: A training day or a holiday could be entered as an all day event. However, 

all day events don’t block your diary, and you can still add individual appointments 

(after all, just because your day is taken up with an event, that doesn’t mean you 

won’t need to make individual appointments during the event). All day events appear 

as a light-blue bar at the top of the day’s entry in your diary.

Meetings: Meetings are like appointments, but you also have the option of inviting 

others to attend. The invitations are sent as iCal attachments to e-mail, so users of 

Microsoft Outlook should be able to reply to them (provided Outlook is properly config-

ured; see the program’s documentation for details, and note that iCal is sometimes 

referred to by the specification number RFC 2446/2447). Once an individual receives 

a meeting invitation, he can click to accept or decline. When Evolution receives this 

response, the individual’s acceptance or declination will be automatically added to 

the diary entry.

Adding or Editing a Diary Entry

These instructions assume the Calendars mode is set to Day view, which shows a full 

working day diary alongside a monthly calendar. To ensure Day view is selected, click the 

Day icon on the main toolbar running across the top of the screen. Day view is the default 

calendar view under Evolution. The other choices are Week, Month, and Work Week 

(which shows appointments during the week in daily columns). If you switch to another 

view, Evolution will always work in that view until you change back again. 

To add a new diary entry, simply select the day in the monthly calendar on the left, and 

then select the time the appointment is to start in the day viewer. Then right-click and 

choose an appointment, an all day event, or a meeting. To edit an existing diary entry, 

double-click its entry in the list.

■Note  When you right-click in Calendars mode, you’ll also see an option to add a task. Adding a task in 

Calendars mode automatically links it to the selected day and time. Task items due on the current day are 

marked in dark blue. 

At its most basic, all an appointment needs in order to be entered into your diary is 

some text in the Summary field, as shown in Figure 27-9. By default, appointments and 

meetings are assumed to last for half an hour, but you can change this by clicking the 

down arrow in the Minutes or Hours fields. For what it’s worth, appointments can go on 

for days—just select a sufficient quantity of hours. You can actually set the meeting dura-

tion to 10,000 hours (wouldn’t that be the meeting from hell?)!
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Figure 27-9. When creating a new appointment, you can add all the details you need, but 

don’t forget to set how long it lasts!

By clicking the Recurrence button, you can set the appointment to be booked into your 

diary according to certain intervals. Start by putting a check in the This Appointment 

Recurs box, and then select a time interval. For example, selecting 1 week will mean that 

the appointment is booked into your diary automatically on a weekly basis. After this, 

select a day of the week for the recurring appointment. Following this, you must specify 

the number of recurrences. You can specify an ending date for the appointment or select 

Forever. In the calendar view at the bottom of the dialog box, you’ll be able to see how this 

looks. Days in bold are those that have appointments. 

It’s also possible to set exceptions, as when the meeting might skip a week. This could 

be useful to work around holidays, for example. Simply click the Add button, and then 

type a date or click the down arrow to select the date from a calendar. 

Once you’re finished, click the Close button to add the details of the recurring event to 

the appointment.

In the case of meeting appointments, you can click the Add button to invite others to 

the meeting via iCal invitations, which will be sent out by e-mail as soon as you’ve finished 

creating the appointment. Simply click the Add button, and in the empty field that appears, 

start typing the contact name of the individual you want to invite. If the person is already 

in your contacts list, the name will be automatically completed, but you can also type 

individual e-mail addresses. By selecting the entry and clicking Edit, you can alter the role 

of the individual. The choices are Chair, Required Participant, Optional Participant, Non-

Participant (that is, somebody you want to inform about the meeting but who doesn’t 

need to attend), and Unknown (for all other instances). 
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Clicking the Free/Busy button will open a new dialog box showing who can and can’t 

attend, according to replies to the invitations sent out (obviously, this is a feature you’ll be 

using after you initially created the appointment). On the left side of the dialog box, you 

will see the list of attendees and also their status: whether they’ve accepted, declined, or 

sent a busy/tentative reply (in which case, you might choose to reschedule the meeting).

Memos and Tasks
The Memos and Tasks modes are the simplest components within Evolution. Memos 

mode allows you to jot down simple notes, and Tasks mode allows you to create a to do list. 

In both modes, which can be selected by clicking their buttons at the bottom left of the 

screen, the program window consists simply of an area where you can click to add a new 

memo/task, a list area, and a preview area, which will show any details of the currently 

selected task. 

In the case of Tasks mode, after you’ve made an entry, clicking the check box alongside 

it will mark it as completed. Completed items appear with strikethrough, as shown in 

Figure 27-10.

Figure 27-10. The Tasks mode lets you catalog chores that you want to do during the day.
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To add a new memo or task, click the bar that reads Click to Add a Memo (or Task), type 

a description, and then press Enter. You will be able to enter more tasks or memos in the 

same field.

Double-clicking a task or memo allows you to fine-tune its details. For example, you 

can add a due date for a task, so you’ll know when the task must be completed. You can 

also add a description for future reference and attach files by clicking the relevant button 

on the toolbar. By clicking the Status Details button in the Task Details dialog box, you can 

also set a percentage figure for completion of the task, as well as its priority, ranging from 

Low to High.

Summary
This chapter has been a whistle-stop tour of Evolution’s main features. We’ve looked at e-mail 

creation and organization, contacts management, working with the appointments calendar, 

and editing the task list. 

Evolution is a powerful program. Be sure to take a look at its help documentation (Help ➤ 

Contents) to learn more about it.

In the next part of the book, we look at keeping your system running. As a first step, the 

next chapter explains how to install, remove, and otherwise manage the software installed 

under Ubuntu.


